Excel funzioni di somma

Sommare con le funzioni matematiche di Microsoft Excel

Autore: Andrea Pacchiarotti
Ultimo aggiornamento: 02 Gennaio 2021
Categoria: Microsoft Office Excel Funzioni di somma

Excel: funzioni di conteggio
Excel funzioni di somma

La polivalenza del foglio elettronico di casa Microsoft permette di fare veramente quasi qualsiasi cosa; allontanandosi dall'uso ristretto agli ambienti lavorativi, si è infatti potuta apprezzare la sua versatilità nell’articolo Costruire un albero genealogico con Microsoft Excel o in quello per Monitorare i guadagni in Bitcoin, oltre a tanti altri che potete vedere nella mappa del sito che tratta Microsoft Office. In questo post vediamo come se la cava a sommare.
Vediamo dunque come sommare celle con le funzioni matematiche di Microsoft Excel.

Sommario Excel funzioni di somma

Excel e funzioni matematiche di somma

Per sommare i valori presenti in un intervallo, potendo eventualmente specificare uno o più criteri, Excel mette a disposizione 3 funzioni:
SOMMA, SOMMA.SE, SOMMA.PIÙ.SE
La funzione SOMMA è disponibile direttamente nell’icona Somma automatica, le altre sempre dalla stessa icona, ma nella voce Altre funzioni… però possono anche essere scritte a mano o rintracciate nella scheda Formule / Altre funzioni / Matematiche e Trogonometriche o infine scelte dall’icona Inserisci funzione
Vediamo degli esempi pratici tenendo presente che nelle funzioni che si andranno a esporre, gli argomenti in rosso corsivo non sono obbligatori.

SOMMA

Addiziona i valori indicati negli argomenti.
Sintassi: SOMMA(num1;num2;...)
Ad esempio =SOMMA(C3:C12) somma i valori contenuti nelle celle da C3 a C12
Prevede i seguenti argomenti:
num1 numero da sommare.
num2;... da 2 a 255 argomenti da sommare.
L'argomento può essere un intervallo, un riferimento di cella, una matrice, una costante, una funzione o il risultato di un'altra funzione; celle vuote, valori logici e testo sono ignorati.

Nelle successive due funzioni è necessario conoscere gli operatori relazionali o di confronto per impostare il criterio o i criteri, in tal senso si hanno a disposizione i seguenti simboli: > maggiore, < minore, >= maggiore uguale, <= minore uguale, = uguale, <> diverso.

SOMMA.SE

Addiziona i valori di un intervallo che soddisfano un criterio specificato.
Sintassi: SOMMA.SE(intervallo;criterio;intervallodasommare)
Ad esempio =SOMMA.SE(D3:D12;">10";C3:C12) somma i valori contenuti nelle celle C3:C12 corrispondenti alle celle del range D3:D12 che sono maggiori di 10
Prevede i seguenti argomenti:
intervallo intervallo, contenente numeri, nomi, riferimenti o matrici, di celle da selezionare in base al criterio; le celle vuote sono ignorate.
criterio numero, espressione, riferimento di cella, testo che specifica le celle da addizionare.
ll criterio può usare riferimenti di cella, operatori relazionali e virgolette (A1, ">=10", "Rossi"). Inoltre contempla l’uso dei caratteri jolly (* e ?) e non fa distinzione tra maiuscole e minuscole.
intervallodasommare celle da addizionare. Se  intervallodasommare è omesso, saranno addizionate le celle di intervallo.
Per trovare un punto interrogativo o un asterisco, digitare una tilde (~) prima del carattere..


SOMMA.PIÙ.SE

Addiziona i valori di un intervallo che soddisfano più di un criterio.
Sintassi: SOMMA.PIÙ.SE(intervallodasommare;intervallocriterio1;criterio1;intervallocriterio2;criterio2;...)
Ad esempio =SOMMA.PIÙ.SE(C3:C12;D3:D12;">10";B3:B12;"Andrea") somma i valori di C3:C12 corrispondenti alle celle D3:D12 che sono maggiori di 10 e il cui nome è Andrea
Prevede i seguenti argomenti:
intervallodasommare indica le celle da addizionare, inclusi numeri, nomi, intervalli o riferimenti di cella; le celle vuote sono ignorate.
intervallocriterio1 intervallo in cui valutare il criterio associato.
criterio1 numero, espressione, riferimento di cella, testo che specifica le celle da addizionare.
ll criterio può usare riferimenti di cella, operatori relazionali e virgolette (A1, ">=10", "Rossi"). Inoltre contempla l’uso dei caratteri jolly (* e ?) e non fa distinzione tra maiuscole e minuscole.
intervallocriterio2;criterio2;... eventuali ulteriori intervalli e criteri fino ad un massimo di 127 coppie con il medesimo numero di righe e colonne di intervallocriterio1.

Excel e funzioni di somma: somma, somma.se, somma.più.se
Excel e funzioni di somma: somma, somma.se, somma.più.se

SOMMA.PIÙ.SE con intervalli nei criteri

Per inserire degli intervalli nei criteri è possibile usare la seguente sintassi:
=SOMMA.PIÙ.SE(C3:C12;C3:C12; ">300"; C3:C12;"<500")
che somma quanti importi maggiori di 300 e minori di 500 sono nell’intervallo C3:C12 (Risultato: 1710)
Volendo è possibile, come in tutte le funzioni, usare i riferimenti di cella nel SOMMA.PIÙ.SE anziché i valori. Per farlo si deve racchiudere l’operatore relazionale tra virgolette e aggiungere una & prima del riferimento di cella. Immaginando che in F8 si metta 300 e in F9 500, si avrà:
=SOMMA.PIÙ.SE(C3:C12;">"&F8; C3:C12;"<"&F9)

Leggi anche come contare le celle e come contare e sommare celle in base al colore.

Per saperne di più su Microsoft Excel potrebbero interessarti i video corsi Excel o questi libri:



Se vuoi approfondire alcuni dei temi trattati, visita la pagina con le mie pubblicazioni cartacee e online.

Se l'articolo ti è piaciuto, condividilo!

Segui l'hashtag #AndreaPacchiarotti