Excel: funzioni di conteggio

Come contare con le funzioni statistiche di Microsoft Excel

Autore: Andrea Pacchiarotti
Ultimo aggiornamento: 19 Marzo 2019
Categoria: Microsoft Office Excel Funzioni di conteggio

Excel: funzioni di conteggio
Excel funzioni di conteggio

La polivalenza del foglio elettronico di casa Microsoft permette di fare veramente quasi qualsiasi cosa, già si è potuta apprezzare la sua versatilità d’uso nell’articolo Costruire un albero genealogico con Microsoft Excel o nella filatelia vediamo ora come se la cava all’opera con le funzioni di conteggio.
Al termine dell'articolo sarà proposto un pratico esecizio riepilogativo.
Vediamo dunque come contare con le funzioni statistiche di Microsoft Excel.

Sommario Excel funzioni di conteggio

Excel e le funzioni statistiche di conteggio

Per conoscere quanti valori sono presenti o meno in un intervallo di celle, potendo eventualmente specificare uno o più criteri, Microsoft Excel rende disponibili 5 funzioni di conteggio:
CONTA.NUMERI, CONTA.VALORI, CONTA.VUOTE, CONTA.SE, CONTA.PIÙ.SE
La funzione CONTA.NUMERI  è disponibile direttamente nell’icona Somma automatica, le altre sempre dalla stessa icona, ma nella voce Altre funzioni… però possono anche essere scritte a mano o rintracciate nella scheda Formule/Altre funzioni/Statistiche o infine scelte dall’icona Inserisci funzione
Vediamo degli esempi pratici tenendo presente che nelle funzioni che si andranno ad esporre, gli argomenti in rosso corsivo non sono obbligatori.

CONTA.NUMERI

Conta quante celle in un intervallo contengono numeri.
Sintassi: CONTA.NUMERI(val1;val2;...)
Argomenti:
val1 riferimento di cella o intervallo di celle in cui contare
val2;... fino a 255 riferimenti di cella o intervalli ulteriori in cui contare.


CONTA.VALORI

Conta quante celle in un intervallo sono non vuote.
Sintassi: CONTA.VALORI(val1;val2;...)
Argomenti:
val1 riferimento di cella o intervallo di celle in cui contare
val2;... fino a 255 riferimenti di cella o intervalli ulteriori in cui contare.


CONTA.VUOTE

Conta quante celle in un intervallo sono vuote.
Sintassi: CONTA.VUOTE(intervallo)
Argomento:
intervallo intervallo di celle in cui contare.

Nelle successive due funzioni è necessario conoscere gli operatori relazionali o di confronto per impostare il criterio o i criteri, in tal senso si hanno a disposizione i seguenti simboli: > maggiore, < minore, >= maggiore uguale, <= minore uguale, = uguale, <> diverso.


CONTA.SE

Conta quante celle in un intervallo soddisfano un criterio specificato.
Sintassi: CONTA.SE(intervallo;criterio)
Argomenti:
intervallo intervallo di celle in cui contare. 
criterio definisce le celle da contare. 
Il criterio può usare riferimenti di cella, operatori relazionali e virgolette, ad esempio A1, ">=10", "Rossi". Inoltre permette l’uso dei caratteri jolly o wildcard (* e ?) e non è case sensitive cioè non fa distinzione tra maiuscole e minuscole.


CONTA.PIÙ.SE

Conta quante celle in un intervallo soddisfano più criteri specificati.
Sintassi: CONTA.PIÙ.SE (intervallocriterio1,criterio1,intervallocriterio2,criterio2;…)
Argomenti:
intervallocriterio1 intervallo di celle in cui contare 
criterio1 definisce le celle da contare
Il criterio può usare riferimenti di cella, operatori relazionali e virgolette, ad esempio A1, ">=10", "Rossi". Inoltre permette l’uso dei caratteri jolly o wildcard (* e ?) e non è case sensitive cioè non fa distinzione tra maiuscole e minuscole. 
intervallocriterio2; criterio2;... eventuali ulteriori intervalli e criteri fino ad un massimo di 127 coppie con il medesimo numero di righe e colonne di intervallocriterio1.

Funzioni di conteggio
Excel esempi di funzioni statistiche di conteggio

Come si evince non esiste una funzione di conteggio che conta i valori testuali (cioè i non numeri), tipo CONTA.TESTO, ma è possibile utilizzare la funzione che nell’esempio restituisce 8 togliendo la a, ovvero:
=CONTA.SE(B3:B12;”*”)
Nel caso si volessero invece contare le celle che non contengono valori testuali, la formula è pressoché identica:
=CONTA.SE(B3:B12;”<>*”)
Per saperne di più su Microsoft Excel potrebbero interessarti questi due libri:


Se vuoi approfondire alcuni dei temi trattati, visita la pagina con le mie pubblicazioni cartacee e online.

Se l'articolo ti è piaciuto, condividilo!

Segui l'hashtag #AndreaPacchiarotti