Seguimi sui social
Profilo LinkedIn Profilo Facebook Profilo Twitter Profilo Google+
Home > Archivio > Excel: funzioni di conteggio

Excel: funzioni di conteggio

Come contare con Microsoft Excel

Autore: Andrea Pacchiarotti
Website: www.andreapacchiarotti.it
Ultimo aggiornamento: 15 Luglio 2017
Categoria: Microsoft Office Excel

Funzioni di Excel in italiano e in inglese

Per conoscere quanti valori sono presenti o meno in un intervallo di celle, potendo eventualmente specificare uno o più criteri, Microsoft Excel rende disponibili 5 funzioni di conteggio:
CONTA.NUMERI, CONTA.VALORI, CONTA.VUOTE, CONTA.SE, CONTA.PIÙ.SE
La funzione CONTA.NUMERI  è disponibile direttamente nell’icona Somma automatica, le altre sempre dalla stessa icona, ma nella voce Altre funzioni… però possono anche essere scritte a mano o rintracciate nella scheda Formule/Altre funzioni/Statistiche o infine scelte dall’icona Inserisci funzione
Vediamo degli esempi pratici tenendo presente che nelle funzioni che si andranno ad esporre, gli argomenti in rosso corsivo non sono obbligatori.

CONTA.NUMERI

Conta quante celle in un intervallo contengono numeri.
Sintassi: CONTA.NUMERI(val1;val2;...)
Argomenti:
val1 riferimento di cella o intervallo di celle in cui contare
val2;... fino a 255 riferimenti di cella o intervalli ulteriori in cui contare.


CONTA.VALORI

Conta quante celle in un intervallo sono non vuote.
Sintassi: CONTA.VALORI(val1;val2;...)
Argomenti:
val1 riferimento di cella o intervallo di celle in cui contare
val2;... fino a 255 riferimenti di cella o intervalli ulteriori in cui contare.


CONTA.VUOTE

Conta quante celle in un intervallo sono vuote.
Sintassi: CONTA.VUOTE(intervallo)
Argomento:
intervallo intervallo di celle in cui contare.

Nelle successive due funzioni è necessario conoscere gli operatori relazionali o di confronto per impostare il criterio o i criteri, in tal senso si hanno a disposizione i seguenti simboli: > maggiore, < minore, >= maggiore uguale, <= minore uguale, = uguale, <> diverso.


CONTA.SE

Conta quante celle in un intervallo soddisfano un criterio specificato.
Sintassi: CONTA.SE(intervallo;criterio)
Argomenti:
intervallo intervallo di celle in cui contare. 
criterio definisce le celle da contare. 
Il criterio può usare riferimenti di cella, operatori relazionali e virgolette, ad esempio A1, ">=10", "Rossi". Inoltre permette l’uso dei caratteri jolly o wildcard (* e ?) e non è case sensitive cioè non fa distinzione tra maiuscole e minuscole.


CONTA.PIÙ.SE

Conta quante celle in un intervallo soddisfano più criteri specificati.
Sintassi: CONTA.PIÙ.SE (intervallocriterio1,criterio1,intervallocriterio2,criterio2;…)
Argomenti:
intervallocriterio1 intervallo di celle in cui contare 
criterio1 definisce le celle da contare
Il criterio può usare riferimenti di cella, operatori relazionali e virgolette, ad esempio A1, ">=10", "Rossi". Inoltre permette l’uso dei caratteri jolly o wildcard (* e ?) e non è case sensitive cioè non fa distinzione tra maiuscole e minuscole. 
intervallocriterio2; criterio2;... eventuali ulteriori intervalli e criteri fino ad un massimo di 127 coppie con il medesimo numero di righe e colonne di intervallocriterio1.

Funzioni di conteggio

Come si evince non esiste una funzione di conteggio che conta i valori testuali (cioè i non numeri), tipo CONTA.TESTO, ma è possibile utilizzare la funzione che nell’esempio restituisce 8 togliendo la a, ovvero:
=CONTA.SE(B3:B12;”*”)
Nel caso si volessero invece contare le celle che non contengono valori testuali, la formula è pressoché identica:
=CONTA.SE(B3:B12;”<>*”)

Scarica questo articolo in PDF.

Se Excel: funzioni di conteggio è stato utile, seguimi sui Social networks cliccando i pulsanti in alto a destra di questa pagina.

Per restare aggiornato sulla pubblicazione di nuovi articoli su Microsoft Office, Adobe e web in generale iscriviti gratuitamente alla newsletter

Se invece vuoi condividere questo articolo nella tua Rete sociale, puoi utilizzare i bottoni qui sotto:


Lascia un commento