Excel: funzioni di conteggio

Contare celle con le funzioni statistiche di Microsoft Excel

Autore: Andrea Pacchiarotti
Ultimo aggiornamento: 29 Ottobre 2020
Categoria: Microsoft Office Excel Funzioni di conteggio

Excel: funzioni di conteggio
Excel funzioni di conteggio

La polivalenza del foglio elettronico di casa Microsoft permette di fare veramente quasi qualsiasi cosa; allontanandosi dall'uso ristretto agli ambienti lavorativi, si è infatti potuta apprezzare la sua versatilità nell’articolo Costruire un albero genealogico con Microsoft Excel o in quello per Monitorare i guadagni in Bitcoin, oltre a tanti altri che potete vedere nella mappa del sito che tratta Microsoft Office. In questo post vediamo come se la cava a contare.
Vediamo dunque come contare celle con le funzioni statistiche di Microsoft Excel.

Sommario Excel funzioni di conteggio

Excel e funzioni statistiche di conteggio

Per conoscere quanti valori sono presenti o meno in un intervallo di celle, potendo eventualmente specificare uno o più criteri, Microsoft Excel rende disponibili 5 funzioni di conteggio:
CONTA.NUMERI, CONTA.VALORI, CONTA.VUOTE, CONTA.SE, CONTA.PIÙ.SE
La funzione CONTA.NUMERI è disponibile direttamente nell’icona Somma automatica, le altre sempre dalla stessa icona, ma nella voce Altre funzioni… però possono anche essere scritte a mano o rintracciate nella scheda Formule / Altre funzioni / Statistiche o infine scelte dall’icona Inserisci funzione
Vediamo degli esempi pratici tenendo presente che nelle funzioni che si andranno a esporre, gli argomenti in rosso corsivo non sono obbligatori.

CONTA.NUMERI

Conta quante celle in un intervallo contengono numeri.
Sintassi: CONTA.NUMERI(val1;val2;...)
Argomenti:
val1 riferimento di cella o intervallo di celle in cui contare
val2;... fino a 255 riferimenti di cella o intervalli ulteriori in cui contare.


CONTA.VALORI

Conta quante celle in un intervallo sono non vuote.
Sintassi: CONTA.VALORI(val1;val2;...)
Argomenti:
val1 riferimento di cella o intervallo di celle in cui contare
val2;... fino a 255 riferimenti di cella o intervalli ulteriori in cui contare.


CONTA.VUOTE

Conta quante celle in un intervallo sono vuote.
Sintassi: CONTA.VUOTE(intervallo)
Argomento:
intervallo intervallo di celle in cui contare.

Nelle successive due funzioni è necessario conoscere gli operatori relazionali o di confronto per impostare il criterio o i criteri, in tal senso si hanno a disposizione i seguenti simboli: > maggiore, < minore, >= maggiore uguale, <= minore uguale, = uguale, <> diverso.


CONTA.SE

Conta quante celle in un intervallo soddisfano un criterio specificato.
Sintassi: CONTA.SE(intervallo;criterio)
Argomenti:
intervallo intervallo di celle in cui contare.
criterio definisce le celle da contare.
Il criterio può usare riferimenti di cella, operatori relazionali e virgolette, ad esempio A1, ">=10", "Rossi". Inoltre permette l’uso dei caratteri jolly o wildcard (* e ?) e non è case sensitive cioè non fa distinzione tra maiuscole e minuscole.


CONTA.PIÙ.SE

Conta quante celle in un intervallo soddisfano più criteri specificati.
Sintassi: CONTA.PIÙ.SE(intervallocriterio1,criterio1,intervallocriterio2,criterio2;…)
Argomenti:
intervallocriterio1 intervallo di celle in cui contare
criterio1 definisce le celle da contare
Il criterio può usare riferimenti di cella, operatori relazionali e virgolette, ad esempio A1, ">=10", "Rossi". Inoltre permette l’uso dei caratteri jolly o wildcard (* e ?) e non è case sensitive cioè non fa distinzione tra maiuscole e minuscole.
intervallocriterio2; criterio2;... eventuali ulteriori intervalli e criteri fino a un massimo di 127 coppie con il medesimo numero di righe e colonne di intervallocriterio1.

Excel e funzioni di conteggio: conta.numeri, conta.valori, conta.vuote, conta.se, conta.più.se
Excel e funzioni di conteggio: conta.numeri, conta.valori, conta.vuote, conta.se, conta.più.se

Come si evince non esiste una funzione di conteggio che conta i valori testuali (cioè i non numeri), tipo CONTA.TESTO, ma è possibile utilizzare il seguente CONTA.SE, che tra virgolette presenta il carattere jolly asterisco:
=CONTA.SE(B3:B12;”*”)
Nel caso si volessero invece contare le celle che non contengono valori testuali, la formula è pressoché identica, ma tra le virgolette della funzione CONTA.SE, l'asterisco è preceduto dal simbolo di diverso:
=CONTA.SE(B3:B12;”<>*”)

Leggi anche come contare e sommare celle in base al colore.

Per saperne di più su Microsoft Excel potrebbero interessarti i video corsi Excel o questi libri:


Se vuoi approfondire alcuni dei temi trattati, visita la pagina con le mie pubblicazioni cartacee e online.

Se l'articolo ti è piaciuto, condividilo!

Segui l'hashtag #AndreaPacchiarotti