#ECDL: funzioni Microsoft Excel

Funzioni, Operatori, Errori

Autore: Andrea Pacchiarotti
Ultimo aggiornamento: 13 Luglio 2020
Categoria: Microsoft Office Excel Funzioni

ECDL: funzioni Excel
#ECDL: funzioni Microsoft Excel

Questo articolo tratta le funzioni Excel per principianti (ma utile anche per sostenere il modulo di Excel per l'ECDL dato che presenterà quasi 20 funzioni diverse), differenziando tra calcoli eseguiti attraverso funzioni nonché mediante operatori, contemplando altresì un link a un risolutore di espressioni per chi non volesse utilizzare quest'applicativo di Microsoft Office.

Sommario ECDL: funzioni Microsoft Excel

Com'è fatta una funzione Excel

La forma di una funzione generica è: =NomeFunzione(argomento1;argomento2;…;argomentoN)
Può essere scritta in maiuscolo e/o minuscolo, ma senza spazi a eccezione, se necessario, delle stringhe delle funzioni SE e CONTA.SE.
L’argomento può essere: riferimento di cella, numero, testo, intervallo.
L’intervallo è un gruppo di celle separate dal simbolo : (due punti), es. A1:A10 significa da A1 ad A10; separandole con ; (punto e virgola) ci si riferisce invece alle singole celle A1 e A10.
Il ; è anche un separatore di argomenti come ad esempio nella seguente formula: =SOMMA(A1:A10;C20:C25) che somma le celle dell’intervallo A1:A10 a quelle dell’intervallo C20:C25.
Al posto dell’intervallo posso anche usare un nome che precedentemente ho assegnato ad esso, nell’esempio precedente la formula potrebbe diventare: =SOMMA(GENNAIO;FEBBRAIO).

Operatori Excel e Funzioni relative

Il calcolo effettuato da alcune funzioni può essere ottenuto utilizzando degli operatori al posto del nome della funzione: ^ al posto della funzione POTENZA, * al posto della funzione PRODOTTO, + per la funzione SOMMA, & in sostituzione della funzione CONCATENA.
Non esiste una funzione DIFFERENZA, mentre RESTO e QUOZIENTE rappresentano l'inesistente funzione DIVISIONE che si ottiene con l'operatore /.

Operatori aritmetici o matematici

^ Elevamento a potenza
=base^esponente
=POTENZA(base;esponente)
=3^2
=POTENZA(A1;A2)
=POTENZA(3;2) Dà 9
Matematiche e Trigonometriche

* Moltiplicazione
=moltiplicando*moltiplicatore
=PRODOTTO(numero;numero)
=3*2
=PRODOTTO(A1;A2)
=PRODOTTO(3;2) Dà 6
Matematiche e Trigonometriche

/ Divisione
=numeratore/denominatore
=QUOZIENTE(numeratore;denominatore)
Il numeratore è il dividendo, il denominatore il divisore
=RESTO(dividendo;divisore)
=5/2
=QUOZIENTE(A1;A2)
=QUOZIENTE(5;2) Dà 2 =RESTO(A1;A2)
=RESTO(5;2) Dà 1
Matematiche e Trigonometriche

+ Addizione
=addendo+addendo
=SOMMA(cella:cella)
=3+2
=SOMMA(A1:A10)
Matematiche e Trigonometriche

- Sottrazione
=minuendo-sottraendo
=3-2

Operatore di concatenazione

Serve per unire in una cella i valori contenuti in altre celle, ad esempio concatenare in A3 il nome ed il cognome contenuti in A1 e A2
&
=cella&cella
=CONCATENA(cella;cella)
=A1&A2
=CONCATENA(A1;A2)
Testo

Operatori relazionali o di confronto

Sono utilizzati per effettuare test in funzioni quali SE e CONTA.SE
> Maggiore
>= Maggiore uguale
< Minore
<= Minore uguale
= Uguale
<> Diverso

Operatori di riferimento

Servono nei casi in cui trascinando una formula non si deve incrementare un riferimento di cella; se la formula è trascinata verso il basso sarà necessario bloccare con il $ (dollaro) la parte numerica della formula (cioè la riga), se invece sarà trascinata verso destra bisognerà bloccare la parte letterale (cioè la colonna). C'è anche la possibilità di trascinare in alto e verso sinistra.
$A$1 Riferimento assoluto
$A1 Riferimento misto, assoluto di colonna, relativo di riga
A$1 Riferimento misto, assoluto di riga, relativo di colonna
A1 Riferimento relativo

Excel esempi funzioni
Funzioni ed operatori in Excel

Altre funzioni Excel

Permette di ottenere la data corrente del computer
=OGGI()
Data e Ora

Fornisce la data e l'orario corrente del computer
=ADESSO()
Data e Ora

Dà la media aritmetica di un intervallo di celle
=MEDIA(cella:cella)
=MEDIA(A1:A10)
Statistiche

Fornisce il valore più basso di un intervallo di celle
=MIN(cella:cella)
=MIN(A1:A10)
Statistiche

Permette di ottenere il valore più alto di un intervallo di celle
=MAX(cella:cella)
=MAX(A1:A10)
Statistiche

Conta le celle che contengono numeri
=CONTA.NUMERI(cella:cella)
=CONTA.NUMERI(A1:A10)
Statistiche

Conta le celle piene
=CONTA.VALORI(cella:cella)
=CONTA.VALORI(A1:A10)
Statistiche

Conta le celle vuote
=CONTA.VUOTE(cella:cella)
=CONTA.VUOTE(A1:A10)
Statistiche

Conta le celle che rispettano un determinato criterio numerico o testuale
=CONTA.SE(cella:cella;criterio)
Il criterio va racchiuso tra “” se è una stringa
=CONTA.SE(A1:A10;”>10”)
=CONTA.SE(A1:A10;10)
=CONTA.SE(F9:F19;A1)
=CONTA.SE(A1:A10;”Anna Mei”)
Statistiche

Permette di arrotondare un numero ad un certo numero di cifre
=ARROTONDA(numero;cifre)
=ARROTONDA(A1;1)
=ARROTONDA(1,952;1)
Matematiche e Trigonometriche

Fornisce la radice quadrata di un numero
=RADQ(numero)
=RADQ(A1)
=RADQ(100)
Matematiche e Trigonometriche

Mostra quanto contenuto nell'argomento se_vero o se_falso in base alla soddisfazione o meno del test; ad esempio se il test è A1>10 e A1 contiene il valore 5, la formula mostrerà quanto contenuto in se_falso; se invece A1 contiene 15, sarà mostrato quanto contenuto in se_vero
=SE(test;se_vero;se_falso)
Il se_vero e il se_falso (che non sono obbligatori) vanno racchiusi tra “” se sono stringhe
=SE(A2<=100;"No";"Sì, ok")
=SE(A2=100;A2+B2,"")
Logiche

È possibile annidare / nidificare le funzioni
=SE(A1>89;"A";SE(A1>0;"B"))
=SE(E(A1>1;B1>5); "No";"Sì, ok")

Messaggi di errore

Errori in cui si può incorrere utilizzando le formule:
#VALORE!: uso il tipo errato di argomento o operando. Es. =a1-a2-a3 dove in a2 c’è una stringa
#DIV/0!: divido un numero per 0 o per una cella vuota
#NOME?: nome di funzione errato o in altra lingua rispetto a quella di Excel
#RIF!: riferimento di cella non valido ovvero elimino celle (che è diverso dal cancellarne il contenuto) che fanno riferimento alla formula
#NUM!: argomenti dei valori numerici non validi per il tipo di funzione, es. =RADQ(-2) o calcolo › o ‹ dei valori limite di Excel (±1*10^308)
#N/D? Nessun valore disponibile.
###### una colonna non sufficientemente larga o uso date o ore negative
Riferimento circolare: formula che usa come argomenti la stessa cella in cui si sta scrivendo la formula, es. in A3 scrivo =SOMMA(A1:A10). L’errore non è introdotto da #, ma da una finestra

Messaggi di errore Excel
Messaggi di errore in Excel

Risolutore delle espressioni

Ho deciso di aggiungere questa ultima parte perché in molti (specialmente i genitori di bambini in età scolare) mi chiedono come risolvere le espressioni senza usare Excel.

Le espressioni si dividono in:

Ordine delle operazioni

Si eseguono prima le Potenze, poi Addizioni e Moltiplicazioni (qualsiasi ordine), infine Sottrazioni e divisioni (ordine di scrittura), ma l’eventuale presenza di una o più parentesi tonde, quadre e graffe, determina delle precedenze nel calcolo:

Le parentesi vanno tolte solo quando le operazioni al loro interno sono state eseguite e sarà rimasto un solo numero (Excel ovviamente sa già tutto questo, l'unica differenza è che usa due volte le parentesi tonde per le quadre e tre volte per le graffe).

Altre regole
Addizioni
Le addizioni possono essere eseguite in qualsiasi ordine, es.: 1+6+3
Calcolo prima 1+6, e scrivo 7+3=10. CORRETTO
O calcolo prima 6+3, scrivo 1+9=10. CORRETTO
Moltiplicazioni
Le moltiplicazioni possono essere eseguite in qualsiasi ordine, es.: 2x3x1
Calcolo prima 2×3, e scrivo 6×1=6. CORRETTO
O calcolo prima 3×1, che fa 3. Dunque 2×3=6. CORRETTO
Sottrazioni
Le sottrazioni vanno eseguite nell’ordine in cui sono scritte, es.: 9-3-1
Calcolo prima 9-3, che fa 6. Scrivo poi 6-1=5. CORRETTO
Ora non rispetto l’ordine di scrittura: calcolo prima 3-1, che fa 2. Scrivo 9-2=7. ERRATO
Divisioni
Le divisioni vanno eseguite nell’ordine in cui sono scritte, es.: 8:4:2
Calcolo prima 8:4, che fa 2. Scrivo 2:2=1. CORRETTO
Ora non rispetto l’ordine di scrittura: calcolo prima 4:2, che fa 2. Scrivo 8:2=4. ERRATO
Esercizio guidato
48:[12+2x(3x4+8)-22]=
L’espressione ha parentesi. Risolvo prima le tonde e poi le quadre. All’interno delle tonde do precedenza alle moltiplicazioni e alle divisioni:
48:[12+2x(12+8)-4]=
48:[12+2x(20)-4]=
48:[12+2x20-4]=
48:[12+40-4]=
48:[52-4]=
48:[48]=
48:48=
1

Nelle espressioni algebriche impiego delle lettere al posto o in aggiunta ai numeri.
Un’espressione algebrica si dice:

Per calcolare il valore numerico di una espressione algebrica sostituisco alle lettere i numeri. Es: 4x2 +3y.
Se x = 2 e y = 3 avrò: 4x2 +3y = 4 (2)2 + 3 (3) = 4 (4) + 9 = 16 + 9 = 25.

Se per i valori attribuiti alle lettere, le operazioni indicate non sono possibili, l'espressione perde di significato, ciò avviene:

Non così, invece, per le espressioni sotto radice con indice dispari. Infatti: Espressioni algebriche Se a =  3 avrò 27, se a 0 -3 avrò -27

Monomi e polinomi sono espressioni algebriche.

Suggerimenti per risolvere le espressioni tramite Risolutore:
- per indicare una moltiplicazione puoi usare uno spazio o il simbolo *
- per le potenze puoi usare l'accento circonflesso ^
- non usare parentesi quadre o graffe, usa solo le tonde
- per indicare le divisioni usa il simbolo / e non :
- per i numeri decimali usa il punto e non la virgola (esempio 1.23)


Per saperne di più su Microsoft Excel potrebbero interessarti i video corsi Excel o questi libri:

Se vuoi approfondire alcuni dei temi trattati, visita la pagina con le mie pubblicazioni cartacee e online.

Se l'articolo ti è piaciuto, condividilo!

Segui l'hashtag #AndreaPacchiarotti