Seguimi sui social
Profilo LinkedIn Profilo Facebook Profilo Twitter Profilo Google+
Home > Archivio > ECDL funzioni Excel

ECDL: funzioni Excel

Funzioni, Operatori, Errori

Autore: Andrea Pacchiarotti
Website: www.andreapacchiarotti.it
Ultimo aggiornamento: Giugno 2016

La forma di una funzione generica è: =NomeFunzione(argomento1;argomento2;…;argomentoN)
Può essere scritta in maiuscolo e/o minuscolo, ma senza spazi ad eccezione, se necessario, delle stringhe della funzione SE e CONTA.SE
L’argomento può essere: riferimento di cella, numero, testo, intervallo
L’intervallo è un gruppo di celle separate dal simbolo :, es. A1:A10 significa da A1 ad A10; separandole con ; ci si riferisce invece alle singole celle A1 e A10
Il ; è anche un separatore di argomenti come ad esempio nella seguente formula: =SOMMA(A1:A10;C20:C25) che somma le celle dell’intervallo A1:A10 a quelle dell’intervallo C20:C25.
Al posto dell’intervallo posso anche usare un nome che precedentemente ho assegnato ad esso, nell’esempio precedente la formula potrebbe diventare: =SOMMA(GENNAIO;FEBBRAIO)

Operatori aritmetici o matematici
  Funzioni Esempio Esempio Libreria Argomenti
^ Elevamento a potenza =base^esponente
=POTENZA(base;esponente)
=3^2
=POTENZA(A1;A2)
=POTENZA(3;2) Dà 9
Matematiche e Trigonometriche 2
* Moltiplicazione =moltiplicando*moltiplicatore
=PRODOTTO(numero;numero)
=3*2
=PRODOTTO(A1;A2)
=PRODOTTO(3;2) Dà 6
Matematiche e Trigonometriche 2 (fino a 255)
/ Divisione =numeratore/denominatore
=QUOZIENTE(numeratore;denominatore)
Il numeratore è il dividendo, il denominatore il divisore
=RESTO(dividendo;divisore)
=5/2
=QUOZIENTE(A1;A2)
=QUOZIENTE(5;2) Dà 2 =RESTO(A1;A2)
=RESTO(5;2) Dà 1
Matematiche e Trigonometriche 2
+ Addizione =addendo+addendo
=SOMMA(cella:cella)
=3+2
=SOMMA(A1:A10)
Matematiche e Trigonometriche 1 (fino a 255)
- Sottrazione =minuendo-sottraendo =3-2    

Operatore di concatenazione
  Funzioni Esempio Esempio Libreria Argomenti
&   =cella&cella
=CONCATENA(cella;cella)
=A1&A2
=CONCATENA(A1;A2)
  Testo 1 (fino a 255)


Operatori relazionali o di confronto
Maggiore
>= Maggiore uguale
Minore
<= Minore uguale
= Uguale
<>  Diverso

Operatori di riferimento
$A$1 Riferimento assoluto
$A1 Riferimento misto, assoluto di colonna, relativo di riga
A$1 Riferimento misto, assoluto di riga, relativo di colonna
A1 Riferimento relativo

Altre funzioni
Funzioni Esempio Libreria Argomenti
=OGGI() =OGGI() Data e Ora 0
=ADESSO() =ADESSO() Data e Ora 0
=MEDIA(cella:cella) =MEDIA(A1:A10) Statistiche 1 (fino a 255)
=MIN(cella:cella) =MIN(A1:A10) Statistiche 1 (fino a 255)
=MAX(cella:cella) =MAX(A1:A10) Statistiche 1 (fino a 255)
=CONTA.NUMERI(cella:cella) =CONTA.NUMERI(A1:A10) Statistiche 1 (fino a 255)
=CONTA.VALORI(cella:cella) =CONTA.VALORI(A1:A10) Statistiche 1 (fino a 255)
=CONTA.VUOTE(cella:cella) =CONTA.VUOTE(A1:A10) Statistiche 1 (fino a 255)
=CONTA.SE(cella:cella;criterio)
Il criterio va racchiuso tra “” se è una stringa
=CONTA.SE(A1:A10;”>10”)
=CONTA.SE(A1:A10;10)
=CONTA.SE(F9:F19;A1)
=CONTA.SE(A1:A10;”Anna Mei”)
Statistiche 2
=ARROTONDA(numero;cifre) =ARROTONDA(A1;1)
=ARROTONDA(1,952;1)
Matematiche e Trigonometriche 2
=RADQ(numero) =RADQ(A1)
=RADQ(100)
Matematiche e Trigonometriche 1
=SE(test;se_vero;se_falso)
Il se_vero e il se_falso (che non sono obbligatori) vanno racchiusi tra “” se sono stringhe
=SE(A2<=100;"No";"Sì, ok")
=SE(A2=100;A2+B2,"")
Logiche 3
È possibile annidare/nidificare le funzioni =SE(A1>89;"A";SE(A1>0;"B"))
=SE(E(A1>1;B1>5); "No";"Sì, ok")
Logiche  

Errori in cui si può incorrere utilizzando le formule
#VALORE!: uso il tipo errato di argomento o operando. Es. =a1-a2-a3 dove in a2 c’è una stringa
#DIV/0!: divido un numero per 0 o per una cella vuota
#NOME?: nome di funzione errato o in altra lingua rispetto a quella di Excel
#RIF!: riferimento di cella non valido ovvero elimino celle (che è diverso dal cancellarne il contenuto) che fanno riferimento alla formula
#NUM!: argomenti dei valori numerici non validi per il tipo di funzione, es. =RADQ(-2) o calcolo › o ‹ dei valori limite di Excel (±1*10^308)
#N/D? Nessun valore disponibile.
###### una colonna non sufficientemente larga o uso date o ore negative
Riferimento circolare: formula che usa come argomenti la stessa cella in cui si sta scrivendo la formula, es. in A3 scrivo =SOMMA(A1:A10). L’errore non è introdotto da #, ma da una finestra

Se Formule per l'esame ECDL è stato utile, seguimi sui Social networks cliccando i pulsanti in alto a destra di questa pagina.

Per restare aggiornato sulla pubblicazione di nuovi articoli su Microsoft Office, Adobe e web in generale iscriviti gratuitamente alla newsletter

Se invece vuoi condividere questo articolo nella tua Rete sociale, puoi utilizzare i bottoni qui sotto:

Clicca il bottone G+1 qui sotto e Condividi per scaricare questo articolo in PDF

Ora clicca qui per prendere il tuo file in PDF


Lascia un commento